Stock Rover NOT affected by Heartbleed OpenSSL security flaw

April 10, 2014

You may have heard about Heartbleed, which is a critical security flaw in OpenSSL. OpenSSL is an implementation of SSL (Secure Sockets Layer) that is commonly used by many websites for secure web traffic between browsers and servers. While Stock Rover uses SSL to ensure the security of our traffic between our servers and your browser, we do not use OpenSSL and therefore are not and never have been affected by this vulnerability. Rest assured that all your data is safe and encrypted.

Other secure websites you use may be affected however. If you are interested in more information on this issue, please see the Heartbleed web site.
Click here to return to the Stock Rover home page.